The Version Option is Invalid – Fix

Whilst most developers were enjoying the Mango SDK and device update, I kept running into a strange problem where app deployment always failed. The error message “The version option is invalid” was always being thrown so I could never test any projects (7.0 or 7.1). Unfortunately, I was also in the middle of updating and creating various apps for 7.0, so I didn’t have time to look in to the problem in any great detail. I tried uninstalling every version of VS2010 and Blend I had on my computer and installing the Mango Beta 1 and 2 from scratch. This didn’t make a difference as the error kept appearing. However, before starting a new project, I decided to take a deeper look into the problem and managed to fix it. So, for anyone who comes across this problem, this information might be helpful:

Read more of this post

Follow

Get every new post delivered to your Inbox.

Join 43 other followers